logo
Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
Sgt_Baker  
#1 Posted : Wednesday, February 15, 2017 1:59:40 PM(UTC)
Sgt_Baker

Rank: Advanced Member

Groups: Registered, Administrators
Joined: 9/14/2016(UTC)
Posts: 225
United Kingdom
Location: London

Was thanked: 6 time(s) in 5 post(s)
http://ultramfcd.com/Downloads/UltraMFCD.Beta.2.6.2.zip

Edited by user Friday, February 24, 2017 7:35:05 AM(UTC)  | Reason: Not specified

Erik  
#2 Posted : Wednesday, February 15, 2017 2:22:48 PM(UTC)
Erik

Rank: Newbie

Groups: Registered
Joined: 2/15/2017(UTC)
Posts: 5
Netherlands
Location: Ultimate Low Country

Hi Baker,

Got an immediate crash of Umfcd after starting it up. Don't even get the chance to set logging on. -Edit- I found the logs anyway but i'm wonder where i can add them here.
2.6.0 worked ok as long as you didn't exited the mission as i said on twitter so. So i guess some changes you made were (on my end) not so good.

greetings, Erik

Edited by user Wednesday, February 15, 2017 2:26:55 PM(UTC)  | Reason: addition

Sgt_Baker  
#3 Posted : Wednesday, February 15, 2017 2:48:30 PM(UTC)
Sgt_Baker

Rank: Advanced Member

Groups: Registered, Administrators
Joined: 9/14/2016(UTC)
Posts: 225
United Kingdom
Location: London

Was thanked: 6 time(s) in 5 post(s)
As in crashes as soon as you launch the uMFCD exe?
Erik  
#4 Posted : Wednesday, February 15, 2017 2:51:19 PM(UTC)
Erik

Rank: Newbie

Groups: Registered
Joined: 2/15/2017(UTC)
Posts: 5
Netherlands
Location: Ultimate Low Country

As in it crashes as soon as i launch uMFCD. Yes.
Sgt_Baker  
#5 Posted : Wednesday, February 15, 2017 2:53:34 PM(UTC)
Sgt_Baker

Rank: Advanced Member

Groups: Registered, Administrators
Joined: 9/14/2016(UTC)
Posts: 225
United Kingdom
Location: London

Was thanked: 6 time(s) in 5 post(s)
What does the Windows Event Log say?
Sgt_Baker  
#6 Posted : Wednesday, February 15, 2017 2:56:00 PM(UTC)
Sgt_Baker

Rank: Advanced Member

Groups: Registered, Administrators
Joined: 9/14/2016(UTC)
Posts: 225
United Kingdom
Location: London

Was thanked: 6 time(s) in 5 post(s)
There's a simple explanation: The Zip is missing one file.

Give me three mins...
Erik  
#7 Posted : Wednesday, February 15, 2017 2:57:49 PM(UTC)
Erik

Rank: Newbie

Groups: Registered
Joined: 2/15/2017(UTC)
Posts: 5
Netherlands
Location: Ultimate Low Country

I found uMFCD logs, so they were made. I could mail them. Don't have webspace to post them here. will that help?
Sgt_Baker  
#8 Posted : Wednesday, February 15, 2017 2:58:37 PM(UTC)
Sgt_Baker

Rank: Advanced Member

Groups: Registered, Administrators
Joined: 9/14/2016(UTC)
Posts: 225
United Kingdom
Location: London

Was thanked: 6 time(s) in 5 post(s)
Re-download and try again. Fixed the Zip file.
Erik  
#9 Posted : Wednesday, February 15, 2017 3:07:45 PM(UTC)
Erik

Rank: Newbie

Groups: Registered
Joined: 2/15/2017(UTC)
Posts: 5
Netherlands
Location: Ultimate Low Country

Works like a charm again. No crash on exit mission.
Sgt_Baker  
#10 Posted : Wednesday, February 15, 2017 3:12:57 PM(UTC)
Sgt_Baker

Rank: Advanced Member

Groups: Registered, Administrators
Joined: 9/14/2016(UTC)
Posts: 225
United Kingdom
Location: London

Was thanked: 6 time(s) in 5 post(s)
Excellent. Did you notice an FPS improvement, or did it not affect you to begin with? (I was one of those extremely hit-and-miss issues, which is why it took so long to track down.)

On my end I was beginning to question my own eyes, whereas other people were reporting no FPS issues at all.

Edited by user Wednesday, February 15, 2017 3:13:55 PM(UTC)  | Reason: Not specified

Erik  
#11 Posted : Wednesday, February 15, 2017 3:13:53 PM(UTC)
Erik

Rank: Newbie

Groups: Registered
Joined: 2/15/2017(UTC)
Posts: 5
Netherlands
Location: Ultimate Low Country

Noted another little error. When exiting an mission and get into another (or even just refly a mission) all uMFCD screens are gone. So it looks like it only works in the first flight you do.
sorry for nagging ;-)

I never had framerate hits to start with, guess i'm lucky since i almost never ever had problems with uMFCD.

Edited by user Wednesday, February 15, 2017 3:14:51 PM(UTC)  | Reason: Not specified

Sgt_Baker  
#12 Posted : Wednesday, February 15, 2017 3:14:39 PM(UTC)
Sgt_Baker

Rank: Advanced Member

Groups: Registered, Administrators
Joined: 9/14/2016(UTC)
Posts: 225
United Kingdom
Location: London

Was thanked: 6 time(s) in 5 post(s)
Yep. Aware of that and still looking in to it. Again, it seems to break sporadically.

And it's not nagging - problems need to be gone!
Holton181  
#13 Posted : Wednesday, February 15, 2017 10:00:51 PM(UTC)
Holton181

Rank: Member

Groups: Registered
Joined: 11/19/2016(UTC)
Posts: 21

Just tested 2.6.2.
Seams to work in both DCSW 1.5.6 and 2.0.5 now. Good Work!
No noticeable FPS drop between running with or without UltraMFCD for both DCSW versions, but no FPS increase either. But it's good enough.
It was no excessive tests though, will do more when I get the time.

Strange thing is, I can't really compare to the UltraMFCD version I have used for some time now, 2.5.6. It say "beta has expired". It did yesterday as well but it still worked then, but not now. I really would like to compare them side by side with same scenarios to see any FPS differences.

Edited by user Wednesday, February 15, 2017 10:01:40 PM(UTC)  | Reason: Not specified

Only Helicopters
DCS 1.5
Win7 Pro 64bit
i7-3820 3.60GHz (OC4.75)
P9X79 Pro
32GB
2xGTX 670 2GB
VG278H + a Dell
PFT Lynx
TrackIR 5
Sgt_Baker  
#14 Posted : Thursday, February 16, 2017 10:56:13 AM(UTC)
Sgt_Baker

Rank: Advanced Member

Groups: Registered, Administrators
Joined: 9/14/2016(UTC)
Posts: 225
United Kingdom
Location: London

Was thanked: 6 time(s) in 5 post(s)
Originally Posted by: Holton181 Go to Quoted Post

Strange thing is, I can't really compare to the UltraMFCD version I have used for some time now, 2.5.6. It say "beta has expired". It did yesterday as well but it still worked then, but not now. I really would like to compare them side by side with same scenarios to see any FPS differences.


Ask and ye shall receive. The old version should now be working again. I made a mistake when editing the deactivation system.

--Baker
Holton181  
#15 Posted : Thursday, February 16, 2017 6:09:03 PM(UTC)
Holton181

Rank: Member

Groups: Registered
Joined: 11/19/2016(UTC)
Posts: 21

Thanks for that!

So, did some more tests this evening.
I'm surprised not getting higher FPS drop with 2.5.6, it gives me a drop of only 2-3FPS compared to without UMFCD, both DCSW 1.5.6 and 2.0.5 (2.0.5 the displays are exported only to the foreground of my main monitor, no other signs of UMFCD), the same as for UMFCD 2.6.2.
I could have sworn I got a bigger drop before.
Anyhow, the only difference between the two versions are that 2.6.2 work correctly in DCSW 2.0.5.

Do you get a FPS increase when using UMFCD yourself? How big then?

The 2-3FPS drop is a low price for the high quality Abris and Shkval though.
Only Helicopters
DCS 1.5
Win7 Pro 64bit
i7-3820 3.60GHz (OC4.75)
P9X79 Pro
32GB
2xGTX 670 2GB
VG278H + a Dell
PFT Lynx
TrackIR 5
Sgt_Baker  
#16 Posted : Friday, February 17, 2017 6:14:35 PM(UTC)
Sgt_Baker

Rank: Advanced Member

Groups: Registered, Administrators
Joined: 9/14/2016(UTC)
Posts: 225
United Kingdom
Location: London

Was thanked: 6 time(s) in 5 post(s)
Originally Posted by: Holton181 Go to Quoted Post

The 2-3FPS drop is a low price for the high quality Abris and Shkval though.


Yeah. Back in the DCS 1.2.x days running uMFCD would actually cause an increase of in-game framerate. When we all moved over to DX11, I changed the strategy such that, as you correctly observe, quality is favoured over performance. This largely affects the Shkval and A-10C TGP - the very systems where a MkI Human Eyeball is still in the loop, looking for those pesky and tiny ground units.

Due to recently-fixed errors in my code, certain users would experience their exported displays rendered at stupid-low FPS rates. It was "inexplicable" to me for ages... but then when you find the problem and go "AH HA! Baker, you moron!" it all makes sense.

But the main "attractive" feature for most users, who don't have eighteen screens etc, is that you can enlarge the Shkval/TGP when needed - thus not having it obscure what would be "world-view" space on, say, a three-screen setup, let alone two screens or one screen.
SubVision  
#17 Posted : Thursday, February 23, 2017 2:55:30 PM(UTC)
SubVision

Rank: Newbie

Groups: Registered
Joined: 2/23/2017(UTC)
Posts: 2

Shkval
Shkval is not being updated in external view

There are Bradley on picture, which are visible on external view.
Shkval should show sky now

F-15 and A-10A have no pop up displays

Ka-50:
UserPostedImage

Edited by user Thursday, February 23, 2017 3:11:22 PM(UTC)  | Reason: Not specified

Sgt_Baker  
#18 Posted : Thursday, February 23, 2017 7:00:25 PM(UTC)
Sgt_Baker

Rank: Advanced Member

Groups: Registered, Administrators
Joined: 9/14/2016(UTC)
Posts: 225
United Kingdom
Location: London

Was thanked: 6 time(s) in 5 post(s)
Originally Posted by: SubVision Go to Quoted Post

Shkval is not being updated in external view



This is a change made by ED. No aircraft targeting pod/system updates in external views any more. You will see the same if you export displays manually. The text overlay will update, but the image will remain static until you re-enter the cockpit.

Other than that, I suggest you upgrade to version 2.6.5. :)
SubVision  
#19 Posted : Thursday, February 23, 2017 7:38:07 PM(UTC)
SubVision

Rank: Newbie

Groups: Registered
Joined: 2/23/2017(UTC)
Posts: 2

Originally Posted by: Sgt_Baker Go to Quoted Post
Originally Posted by: SubVision Go to Quoted Post

Shkval is not being updated in external view



This is a change made by ED. No aircraft targeting pod/system updates in external views any more. You will see the same if you export displays manually. The text overlay will update, but the image will remain static until you re-enter the cockpit.

Other than that, I suggest you upgrade to version 2.6.5. :)


I had already) had this post openned.

If i make display + MFCD mode in settings, it will update then?
Sgt_Baker  
#20 Posted : Friday, February 24, 2017 7:21:08 AM(UTC)
Sgt_Baker

Rank: Advanced Member

Groups: Registered, Administrators
Joined: 9/14/2016(UTC)
Posts: 225
United Kingdom
Location: London

Was thanked: 6 time(s) in 5 post(s)
Originally Posted by: SubVision Go to Quoted Post

If i make display + MFCD mode in settings, it will update then?


Nope. It will behave in exactly the same manner whether you are using UltraMFCD or setting up exports manually. It's hard-coded in to DCS by Eagle Dynamics.

If you want it changed, I suggest you log it as a bug report with them. :)

--Baker
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.